4.6.0 does not play notification sound on Windows OS

Description

Original report: https://github.com/mattermost/desktop/issues/1395

Summary
4.6.0 does not play notification sound on Windows OS

Environment
Operating System: Windows 7, Windows 10 1909, 2004, 20H2
Mattermost Desktop App version: 4.6.0 (exe installer)
Mattermost Server version: 5.28.0

Steps to reproduce
1. Receive notification in desktop app

Expected behavior
When receiving notification, see toast (banner) notification and hear a notification sound.

Observed behavior
when receiving notification, see toast (banner) notification, but no notification sound is played.

Notes
To test, I spun up fresh installs of Windows 7, Windows 10 1909, Windows 10 2004 & Windows 10 20H2. Also fresh installs of Solus Budgie, Linux Mint 20. On the windows installs, I used the .exe installer. Of these, only the Linux desktop app played the notification sounds. On each virtual machine, I was able to select the new custom notification sound and hear them when selecting one, but no sound ever played when receiving notifications. If I install 4.5.4 on windows, notification sounds played as expected.

QA Test Steps

see steps in PR

Activity

Show:
Jelena Gilliam
October 24, 2020, 2:42 PM

Tested and Passed on 4.6.1 on macOS, Windows and Ubuntu.

  • Custom sounds plays on the desktop app when new notification is received.

QA note: Test already exists. Closing.

Done
Your pinned fields
Click on the next to a field label to start pinning.

Mana

1

Assignee

Guillermo Vayá

QA Assignee

Jelena Gilliam

Reporter

Amy Blais

Fix versions

Mattermost Team

Web Platform [Messaging]

Labels

QA Testing Areas

Notifications - Desktop