Allow plugin marketplace to automatically install specific plugin versions from feature flags.

Description

Spec: https://docs.google.com/document/d/1B2oOeQsH0TiWObAMbHw_jLOSUjMRNfd3j8Df-2QKkDc/edit

Marketplace should be able to install a specific version of a plugin from the feature flags config.
"" will be taken as "keep current"
This ticket my be split into multiple if necessary.

QA Test Steps

None

Mana

None

Assignee

Unassigned

QA Assignee

None

Reporter

Christopher Speller

Epic Link

Fix versions

Mattermost Team

Workflows

Labels

QA Testing Areas

Other (write in QA test steps)

GitHub Issue

None

Components

None
Configure