No visible focus on login screen directly after adding new server

Description

Desktop app v4.5.0-rc2 on Windows, macOS & Linux

1 - Click + to the right of the tabs and fill in fields to add new server
2 - Click Add button
3 - Observe login fields on next screen

Expected: Cursor present in Username field and glow surrounding field awaiting user input
Observed: No cursor even after you click in field and start typing and switch between fields

Notes:

  • As soon as you interact with any element outside of the desktop window then the fields behave as expected

  • Possible regression as I tested it in the current live version (v4.4.2) and it worked as expected on Windows 10

  • Logging out of a server than back in also worked as expected

QA Test Steps

None

Activity

Show:
Steve Mudie
June 27, 2020, 2:00 AM

Closing per comments above.

Guillermo Vayá
June 26, 2020, 10:53 AM

if it is indeed an electron bug (couldn't find anything that looked like it) it might be resolved in future versions, closing for now, but i'll keep an eye for it

Guillermo Vayá
June 24, 2020, 4:57 PM

after going through the ticket with we determined it might be an electron bug, as soon as you start typing the input box gets the characters. if it is indeed an electron bug, we can’t do anything atm.

Guillermo Vayá
June 18, 2020, 1:37 PM

Moving to apps for discussion

when you are back, can we go over this ticket? i ran out of ideas

Steve Mudie
June 12, 2020, 8:55 PM

I updates the title as during Desktop app tests we discovered this to be the same on all systems.
Windows, macOS & Linux.

Won't Fix
Your pinned fields
Click on the next to a field label to start pinning.

Assignee

Guillermo Vayá

QA Assignee

Steve Mudie

Reporter

Steve Mudie

Fix versions

Mattermost Team

Core Features

QA Testing Areas

AD/LDAP

Components