[webapp] text from links are cut, while markdown looks right

Description

when adding a PR link, autolinker substitutes for the right markdown to display, but it is rendered without the last part. I've also seen this behaviour on github bot summary message

expected: text from link's markdown is displayed fully
observed: see screenshots

seen on firefox and desktop app, release and daily

it might have to do with: although i started seen this on release server yesterday

QA Test Steps

Test that full link text displays even when it exists in multiple elements as in the example provided.
Regression test more common cases of posting a link in markdown.
As a precaution, regression test plugin pop-overs.

Activity

Show:
Dylan Haussermann
July 10, 2020, 3:07 PM
Edited
Dylan Haussermann
June 19, 2020, 9:08 PM

Leaving task open for v5.25

Dylan Haussermann
June 19, 2020, 9:01 PM

Tested and passed.
Repeated same testing as above no issues with displaying markdwn links when the pop=over functionality ios active.

I did find an issue with the pop-overs themselves on older server version - created to triage and address this.

Dylan Haussermann
June 19, 2020, 6:49 PM
Edited

Tested and passed on 5.24-rc1

  • Tested that full link text displays even when it exists in multiple elements as in the examples provided

     

  • Regression tested more common cases of posting a link in markdown

  • As a precaution, regression tested plugin pop-overs

Guillermo Vayá
June 17, 2020, 9:54 PM
Edited

another text sample that renders incorrectly:

 

Another one:

Done

Mana

None

Assignee

Michael Kochell

QA Assignee

Dylan Haussermann

Reporter

Guillermo Vayá

Epic Link

None

Mattermost Team

Sustained Engineering

Sprint

None

QA Testing Areas

Plugins

GitHub Issue

None

Components

None

Severity

None