Switching to an unread channel sometimes gets stuck at "Loading..."

Description

I've split this issue off of https://mattermost.atlassian.net/browse/MM-18576 to explicitly track the issues seen by and others where the network requests for the `/unreads` endpoint succeed, but the client appears to be stuck in an endless "Loading..." state.

Reproduction steps currently unknown.

QA Test Steps

See description

Activity

Show:
Eric Sethna
February 26, 2020, 4:53 PM

Adding the v5.21 fix version, we should try to prioritize for the quality release. cc//

Steve Mudie
March 11, 2020, 2:49 PM

Working as expected.

Sudheer Timmaraju
March 24, 2020, 12:26 PM

Reopening as this is still happening at few resolutions and zoom level with chrome browser(Desktop app). More info https://forum.mattermost.org/t/switching-to-unread-channel-displays-arbitrarily-old-messages/9221.

Temp workaround:
1. On chrome and on desktop zooming the app by a notch fixes this.
2. Use alternate browsers such as firefox or safari.

Sudheer Timmaraju
March 24, 2020, 9:03 PM

Reverting the specific logic added for chrome specifically as it seemed to be fixed on chrome end now. This should resolve to the same behaviour as other browsers

Steve Mudie
March 27, 2020, 3:21 PM

Tested and passed
No tests needed or linked to
Closing

Done

Mana

8

Assignee

Sudheer Timmaraju

QA Assignee

Steve Mudie

Reporter

Sudheer Timmaraju

Epic Link

None

Fix versions

Mattermost Team

Sustained Engineering

Sprint

None

QA Testing Areas

Other (write in QA test steps)

GitHub Issue

None

Components

None

Severity

S1_data_loss_or_crash
Configure